Bewertung: 5 / 5

Stern aktivStern aktivStern aktivStern aktivStern aktiv
 

Bei Fragen zu raspiBackup siehe diese Seite.

Wenn es Fragen oder Kommentare zu einem Artikel gibt kommt man mit einem geposteten Kommentar auf der Webseite mit mir in Kontakt. Damit kann dann auch die Community an den Fragen und Kommentaren teilhaben und teilnehmen.

In allen anderen Fällen einfach eine eMail schreiben an

Kontakt

Wer eine verschlüsselte eMail schreiben möchte findet hier meinen öffentlichen PGP Schlüssel.

Kommentar schreiben

*** Hinweis ***

Kommentare sind erwünscht. Aber um lästige Spamposts abweisen zu können gibt es ein paar Dinge die zu beachten sind:
  1. Kommentare mit dem Text http werden sofort zurückgewiesen mit der Meldung Sie sind nicht berechtigt den Tag zu verwenden. zz
  2. Kommentare werden manuell überprüft und es dauert deshalb in der Regel einen Tag bis sie veröffentlicht werden.

    Kommentare   
    #67 framp 2021-04-27 09:40
    Moin Thomas,

    es gibt eine Seite von mir wo viele Fehlermeldungen , deren Ursach und Loesung beschrieben sind. U.A. findet sich das RBK0196W (HTTPS://www.linux-tips-and-tricks.de/de/fehlermeldungen/#m0196) ;-)

    Cu framp
    Zitieren
    #66 Thomas 2021-04-26 15:13
    hallo framp,
    zuerst einmal vielen dank für das programm raspibackup.
    bin erst vor kurzem darauf gestoßen und es war genau das, was ich gesucht habe.
    zur folgenden frage benötige ich hilfe.
    beim sichern mit rsync über sshts tauchen immer wieder folgende fehler auf:
    RBK0196W: /backup unterstützt keine Hardlinks. (ok steht in der doku)
    danach jede menge:
    rsyn: failed to set times on "dateipfad/dateiname": no such file or directory
    am ende stoppt er dann mit dem fehler RBK0021E und bricht ab. was gibt es hier zu beachten? wo liegt der fehler? tar backups funktionieren in ein sshfs verzeichnis
    vielen dank und viele grüße
    thomas
    Zitieren
    #65 framp 2020-11-27 10:56
    Moin Guenter,

    ich weiss nicht welches Dateisystem Du auf der Fritte nimmst. Zu den Laengen siehe HTTPS://en.wikipedia.org/wiki/Comparison_of_file_systems#Limits. Ausserdem bitte ich Dich FAQ47 (HTTPS://www.linux-tips-and-tricks.de/de/faq/#a47) zu lesen. In dem Forum wird Dir bestimmt weitergeholfen. Auch ich bin da vertreten :-)

    Cu framp
    Zitieren
    #64 Günter 2020-11-27 08:23
    Moin framp,
    einen Hinweis habe ich noch. Ich habe das Gefühl, das das gemountete Laufwerk in der Namensgebung zu lang ist !?? Kann das sein ?? Mit cd komme ich in den letzten Ordner nicht rein. Mit der TAB-Taste als Auto-Vervollständigung kommt linux auch nur bis Ordnerbezeichnung ....*20 ... dann ist Schluss.
    .... hmmmm ...
    Vielleicht hilft dir das weiter.
    Cu framp
    Zitieren
    #63 Günter 2020-11-27 08:16
    Moin framp,
    ich habe mit linux ein völlig neues Feld betreten, hoffe aber das du mit meinen Darstellungen und Fragen was anfangen kannst. Ich habe raspiBackup v0.6.5.1 nach deinem tollen Seiten mE nach ordnungsgemäß eingerichtet. Danach raspiBackuoWrapper und danach pishrink. Die Sicherung mit raspiBackup läuft auch korrekt durch und die Datei *.img wird auf einem gemounteten NAS der Fritz.box angelegt.
    Würde mich freuen, wenn du mir helfen könntest. Vielen Dank im vorraus ... perry ....Cu framp

    Folgender Fehler:
    Backup succeeded :-)
    pishrink.sh v0.1.2
    pishrink.sh: Gathering data ...
    Error: Error opening /media/fritznas/raspberrypi4-iob/raspberrypi4-iob-dd-backup-20201126-225436/raspberrypi4-iob-dd-backup-20201126-225436.img: Veraltete Da(file handle)
    pishrink.sh: ERROR occured in line 273: parted failed with rc 1
    pishrink.sh: Possibly invalid image. Run 'parted /media/fritznas/raspberrypi4-iob/raspberrypi4-iob-dd-backup-20201126-225436/raspberrypi4-iob-dd-backup-20201t B print' manually to investigate ...
    Zitieren
    #62 framp 2020-11-08 20:01
    Hm ... dann schick mir doch mal bitte das debug log zu. Meine eMailAdresse findest Du auf der Kontaktseite.
    Zitieren
    #61 Jörg 2020-11-08 19:50
    Habe umgestellt auf /backup Hat aber kein erfolg gebracht

    root@Raspi-server:/# findmnt
    TARGET SOURCE FSTYPE OPTIONS
    / /dev/mmcblk0p2 ext4 rw,noatime
    ├─/dev devtmpfs devtmpfs rw,relatime,size=446324k,nr_inodes=111581,mode=755
    │ ├─/dev/shm tmpfs tmpfs rw,nosuid,nodev
    │ ├─/dev/pts devpts devpts rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000
    │ └─/dev/mqueue mqueue mqueue rw,relatime
    ├─/sys sysfs sysfs rw,nosuid,nodev,noexec,relatime
    │ ├─/sys/kernel/security securityfs securityfs rw,nosuid,nodev,noexec,relatime
    │ ├─/sys/fs/cgroup tmpfs tmpfs ro,nosuid,nodev,noexec,mode=755
    │ │ ├─/sys/fs/cgroup/unified cgroup2 cgroup2 rw,nosuid,nodev,noexec,relatime,nsdelegate
    │ │ ├─/sys/fs/cgroup/systemd cgroup cgroup rw,nosuid,nodev,noexec,relatime,xattr,name=systemd
    │ │ ├─/sys/fs/cgroup/devices cgroup cgroup rw,nosuid,nodev,noexec,relatime,devices
    │ │ ├─/sys/fs/cgroup/perf_event cgroup cgroup rw,nosuid,nodev,noexec,relatime,perf_event
    │ │ ├─/sys/fs/cgroup/freezer cgroup cgroup rw,nosuid,nodev,noexec,relatime,freezer
    │ │ ├─/sys/fs/cgroup/pids cgroup cgroup rw,nosuid,nodev,noexec,relatime,pids
    │ │ ├─/sys/fs/cgroup/net_cls,net_prio cgroup cgroup rw,nosuid,nodev,noexec,relatime,net_cls,net_prio
    │ │ ├─/sys/fs/cgroup/cpu,cpuacct cgroup cgroup rw,nosuid,nodev,noexec,relatime,cpu,cpuacct
    │ │ ├─/sys/fs/cgroup/blkio cgroup cgroup rw,nosuid,nodev,noexec,relatime,blkio
    │ │ └─/sys/fs/cgroup/cpuset cgroup cgroup rw,nosuid,nodev,noexec,relatime,cpuset
    │ ├─/sys/fs/bpf none bpf rw,nosuid,nodev,noexec,relatime,mode=700
    │ ├─/sys/kernel/debug debugfs debugfs rw,relatime
    │ ├─/sys/kernel/config configfs configfs rw,relatime
    │ └─/sys/fs/fuse/connections fusectl fusectl rw,relatime
    ├─/proc proc proc rw,relatime
    │ └─/proc/sys/fs/binfmt_misc systemd-1 autofs rw,relatime,fd=35,pgrp=1,timeout=0,minproto=5,maxproto=5,direct
    ├─/run tmpfs tmpfs rw,nosuid,nodev,mode=755
    │ ├─/run/lock tmpfs tmpfs rw,nosuid,nodev,noexec,relatime,size=5120k
    │ ├─/run/rpc_pipefs sunrpc rpc_pipefs rw,relatime
    │ └─/run/user/1000 tmpfs tmpfs rw,nosuid,nodev,relatime,size=95920k,mode=700,uid=1000,gid=1000
    │ └─/run/user/1000/gvfs gvfsd-fuse fuse.gvfsd-fuse rw,nosuid,nodev,relatime,user_id=1000,group_id=1000
    ├─/boot /dev/mmcblk0p1 vfat rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro
    ├─/backup //192.168.178.39/backup_autom
    │ cifs rw,relatime,vers=2.1,cache=strict,username=backup,domain=workgroup,uid=0,noforceuid,gid=0,noforcegid,addr=192.168.178.39,file_mode=0755,dir_mode=0755,soft,nounix,server
    └─/media/pi/CFC7-074A /dev/sda1 vfat rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,showexec,utf8,flush,errors=remount-ro
    Zitieren
    #60 framp 2020-11-08 19:35
    Hm ... zeige doch mal die Ausgabe von

    findmnt
    Zitieren
    #59 framp 2020-11-08 19:21
    Moin Joerg,

    es ist ungeschickt /mnt zu nehmen :sad: Der Standard Backuppfad von raspiBackup ist /backup. Ich empfehle auch diesen oder einen dedizierten anderen Pfad zu nehmen. Warum aber der mount frueher ohne Probleme durchging weiss ich nicht. Das erfordert eine intensivere Problemanalyse. Ich empfehle von /mnt auf /backup umzustellen und gehe davon aus dass es dann funktioniert.

    Cu framp
    Zitieren
    #58 Jörg 2020-11-08 19:20
    Nochmal:

    umount funktioniert leider auch nicht. Ob wohl ich auf den Ordner per CD zugreifen kann.
    Ich verstehe es irgendwie nicht

    root@Raspi-server:/home/pi# umount /mnt
    umount: /mnt: not mounted.
    root@Raspi-server:/home/pi# umount /mnt/Raspi-server
    umount: /mnt/Raspi-server: not mounted.
    root@Raspi-server:/home/pi# cd /mnt/Raspi-server
    root@Raspi-server:/mnt/Raspi-server# ls
    Raspi-server-dd-backup-20190317-170001 Raspi-server-dd-backup-20190922-170002 Raspi-server-dd-backup-20200112-170001 Raspi-server-dd-backup-20201025-170002 Raspi-server-dd-backup-20201108-180133
    Raspi-server-dd-backup-20190505-170001 Raspi-server-dd-backup-20191110-170001 Raspi-server-dd-backup-20200223-170001 Raspi-server-dd-backup-20201108-173910
    Raspi-server-dd-backup-20190707-170001 Raspi-server-dd-backup-20191222-170002 Raspi-server-dd-backup-20200308-170001 Raspi-server-dd-backup-20201108-174827
    root@Raspi-server:/mnt/Raspi-server# nano /usr/local/etc/raspiBackup.conf
    Zitieren
    #57 Jörg 2020-11-08 19:14
    Hallo framp,

    /mnt mounte den Zielordner wohin das Backup geschrieben wird. Der liegt auf einem anderen Rechner. Komischer weise lief es bisher immer so und nach einem apt update nicht mehr :sad:

    Der Backup-Pfad ist ja: /mnt/Raspi-server/ +Neuer Ordner mit aktuellem Datum +Zeit

    Hier der mount befehl aus der config-Datei


    # Durch && getrennte Befehle, die vor dem Starten des Backups auszuführen sind
    DEFAULT_STOPSERVICES="mount -t cifs -o user=backup,password=XXXX,domain=workgroup //192.168.178.39/backup_autom /mnt && service cron stop && service apache2 stop && service smbd stop && service mysql stop && service postfix$

    # Durch && getrennte Befehle, die nach dem Starten des Backups auszuführen sind
    DEFAULT_STARTSERVICES="service cron start && service apache2 start && service smbd start && service mysql start && service postfix start && service dovecot start && service fetchmail start"

    MfG Jörg
    Zitieren
    #56 framp 2020-11-08 18:41
    Moin Joerg,

    offensichtlich hast Du irgendwas an /mnt gemounted. /mnt wird von raspiBackup genutzt beim Backup. Mit mount sollte da etwas fuer /mnt auftauschen. Mit sudo umount /mnt machst Du /mnt frei. Die Frage ist warum und was Du an /mnt gemountet hast und ob es benoetigt wird.

    Cu framp
    Zitieren
    #55 Jörg 2020-11-08 18:36
    Guten Abend,

    ich benutze raspibackup.sh mittlerweile seit einem Jahr und lasse automatisch Backups erzeugen.
    Allerdings funktioniert dies seit kurzen nicht mehr.
    Es gibt irgendein Problem mit dem Mounten des Zielordners.
    Ich kann nur nicht herausfinden, wo der Fehler ist.
    Per Konsole kann ich auf den Zielordner zugreifen und per NANO auch eine neue Datei dort anlegen

    Ich Hoffe mir kann hier jemand weiterhelfen.

    Hier die Logs:
    root@Raspi-server:/mnt/Raspi-server/Raspi-server-dd-backup-20200927-170001# bash /usr/local/bin/raspiBackup.sh
    --- RBK0009I: Raspi-server: raspiBackup.sh V0.6.4.2 (2184fa5) So 8. Nov 18:23:00 CET 2020 gestartet.
    --- RBK0141I: Nur der von den definierten Partitionen belegte Speicherplatz wird gesichert.
    --- RBK0151I: Backuppfad /mnt wird benutzt.
    mount error(16): Device or resource busy
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    ??? RBK0048E: Ein Fehler trat beim Beenden von Services auf. RC 32.
    --- RBK0032I: Bitte warten bis aufgeräumt wurde.
    lsof: WARNING: can't stat() fuse.gvfsd-fuse file system /run/user/1000/gvfs
    Output information may be incomplete.
    --- RBK0105I: Neues Backupverzeichnis /mnt/Raspi-server/Raspi-server-dd-backup-20201108-182300 wird gelöscht.
    rm: das Entfernen von '/mnt/Raspi-server/Raspi-server-dd-backup-20201108-182300' ist nicht möglich: Das Verzeichnis ist nicht leer
    ??? RBK0005E: Backup fehlerhaft beendet. Siehe vorhergehende Fehlermeldungen.
    --- RBK0010I: Raspi-server: raspiBackup.sh V0.6.4.2 (2184fa5) So 8. Nov 18:23:30 CET 2020 beendet.
    root@Raspi-server:/mnt/Raspi-server/Raspi-server-dd-backup-20200927-170001# cd /mnt/Raspi-server/Raspi-server-dd-backup-20201108-182300
    root@Raspi-server:/mnt/Raspi-server/Raspi-server-dd-backup-20201108-182300# nano test.img
    root@Raspi-server:/mnt/Raspi-server/Raspi-server-dd-backup-20201108-182300#

    MfG Jörg
    Zitieren
    #54 framp 2020-10-02 15:49
    Moin Gregor,

    solange Du bei der Stange bleibst und ich noch Licht am Horizont sehe ist das OK.

    Bist Du Dir sicher dass an /media/backup was gemounted und schreibbar ist? Anders kann ich mir den Fehler nicht erklaeren. Findest Du im Debuglog nach der Meldung RBK0044I irgendwelche auffaelligen Meldungen von dd. Auch wird im Debuglog verschiedentlich mount aufgerufen und Du kannst pruefen on /media/backup gemounted ist.

    Cu framp
    Zitieren
    #53 Gregor 2020-10-02 14:48
    Hallo Framp,

    ich will deine Geduld nicht überstrapazieren. Wenn dir meine Anfragen Zuviel werden sag es einfach. Leider ist noch nicht alles im Lot:

    pi@raspberrypi:~$ sudo raspiBackup.sh -c -L varlog -u /var/log/raspiBackup/*
    --- RBK0009I: raspberrypi: raspiBackup.sh V0.6.5.1 (c295a0e) Fr Okt 2 14:03:28 CEST 2020 gestartet.
    --- RBK0128I: Logdatei ist /var/log/raspiBackup/raspberrypi.log.
    --- RBK0116I: Konfigurationsdatei /usr/local/etc/raspiBackup.conf wird benutzt.
    --- RBK0151I: Backuppfad /media/Backup wird benutzt.
    --- RBK0182I: Vor dem Backup ausgeführte Befehle: 'mount UUID=2428955A28952C34'.
    --- RBK0008I: Services werden gestoppt: 'systemctl stop openhab2 && systemctl stop debmatic' .
    --- RBK0081I: Backup vom Typ tgz wird in /media/Backup/raspberrypi/raspberrypi-tgz-backup-20 201002-140327 erstellt.
    --- RBK0036I: Partitionslayout wird gesichert.
    --- RBK0044I: Backup der Bootpartition wird in /media/Backup/raspberrypi/raspberrypi-tgz-bac kup-20201002-140327/raspberrypi-backup.img erstellt.
    dd: konnte '/media/Backup/raspberrypi/raspberrypi-tgz-backup-20201002-140327/raspberrypi-bac kup.img' nicht öffnen: Datei oder Verzeichnis nicht gefunden
    ??? RBK0178E: Erzeugung von /media/Backup/raspberrypi/raspberrypi-tgz-backup-20201002-140327 /raspberrypi-backup.img Datei endet fehlerhaft mit RC 1.
    --- RBK0033I: Bitte warten bis aufgeräumt wurde.
    --- RBK0007I: Services werden gestartet: 'systemctl start debmatic && systemctl start openha b2'.
    --- RBK0181I: Nach dem Backup ausgeführte Befehle: 'umount UUID=2428955A28952C34'.
    --- RBK0043I: Unvollständiges Backup /media/Backup/raspberrypi/raspberrypi-tgz-backup-202010 02-140327 in wird gelöscht. Das kann etwas dauern. Bitte Geduld.
    --- RBK0049I: Meldungen wurden in /var/log/raspiBackup/raspberrypi.msg gesichert.
    --- RBK0026I: Debug Logdatei wurde in /var/log/raspiBackup/raspberrypi.log gesichert.
    --- RBK0010I: raspberrypi: raspiBackup.sh V0.6.5.1 (c295a0e) Fr Okt 2 14:04:09 CEST 2020 be endet mit Returncode 114.
    ??? RBK0005E: Backup fehlerhaft beendet. Siehe vorhergehende Fehlermeldungen.
    Zitieren
    #52 framp 2020-10-02 09:49
    Moin Gregor,

    raspiBackup will ein Log auf der Backuppartition erstellen bevor die Exits aufgerufen werden und die Backuppartition gemounted ist :sad:

    Man kann den Log ausschalten mit der undokumentierten Option -l off (kleines L). Es kann aber sein dass das nicht mehr funktioniert da diese Option eigentlich nicht mehr genutzt werden soll und deshalb nicht mehr getestet wird ob sie funktioniert. Ein Versuch ist es jedenfalls wert. Allerdings bekommst Du dann kein Debuglog was im Problemfall von mir angefragt wird.

    Es gibt aber einen anderen Workaround fuer Dich. Mit der undokumentierten Option -L kannst Du bestimmen wo das Log abzulegen ist. Es gibt die Parameter syslog, varlog und current. Wie der Name sagt wird das Log dann ins syslog geschrieben, ineine Datei in /var/log/raspiBackup oder im aktuellen Verzeichnis. Du musst dann aber vermutlich noch ein Excludestatement mit Option -u nutzen um dieses Log vom Backup auszuschliessen.

    Ich drueck die Daumen dass es nun klappt ;-)

    Cu framp
    Zitieren
    #51 Gregor 2020-10-02 07:59
    Hallo Framp,

    vielen Dank für diesen Geheimtipp. Das mounten und umounten klapp jetzt. Leider hat sich aber eine neue Fehlermeldung ergeben:

    /usr/local/bin/raspiBackup.sh: Zeile 1490: /media/Backup/raspberrypi/raspberrypi-tgz-backup-20201001-193329/raspiBackup .log: Datei oder Verzeichnis nicht gefunden
    /usr/local/bin/raspiBackup.sh: Zeile 1490: /media/Backup/raspberrypi/raspberrypi-tgz-backup-20201001-193329/raspiBackup .log: Datei oder Verzeichnis nicht gefunden
    /usr/local/bin/raspiBackup.sh: Zeile 1490: /media/Backup/raspberrypi/raspberrypi-tgz-backup-20201001-193329/raspiBackup .log: Datei oder Verzeichnis nicht gefunden
    /usr/local/bin/raspiBackup.sh: Zeile 1490: /media/Backup/raspberrypi/raspberrypi-tgz-backup-20201001-193329/raspiBackup .log: Datei oder Verzeichnis nicht gefunden
    /usr/local/bin/raspiBackup.sh: Zeile 1490: /media/Backup/raspberrypi/raspberrypi-tgz-backup-20201001-193329/raspiBackup .log: Datei oder Verzeichnis nicht gefunden

    Scheinbar können die Backupdaten nicht erzeugt werden:
    ??? RBK0178E: Erzeugung von /media/Backup/raspberrypi/raspberrypi-tgz-backup-20201001-193329/raspberrypi-backup.img Datei endet fehlerhaft mit RC 1.

    Lg Gregor
    Zitieren
    #50 framp 2020-10-01 09:48
    Moin Gregor,

    die Pruefung ob was gemounted ist wird vor den Exits gemacht. Somit kannst Du mit Deinen Bemuehungen keinen Erfolg haben :sad:

    Ich erstelle mir mal einen Issue dazu und werde das in der naechsten Release aendern. Bis dahin kannst Du diesen Check aber disablen mit der undokumentierten Option -c ;-)

    Beruecksichtige aber auch dass es momentan noch einen bekannten Bug in raspiBackup gibt dass im Fehlerfalle die Postexits nicht aufgerufen werden. Im erfolgsfall werden sie aber aufgerufen. Das wird auch in der naechsten Release gefixed sein.

    Siehe dazu auch die offenen raspiBackup Issues: https://github.com/framps/raspiBackup/issues

    Cu framp
    Zitieren
    #49 Gregor 2020-10-01 08:07
    Hallo,

    ich habe mir wirklich alle Mühe gegeben auf deiner wirklich toll dokumentierten Seite die Lösung für mein Problem zu finden bevor ich ein Kommentar schreibe. Leider hatte ich keinen Erfolg.
    Ich möchte eine USB-Stick vor dem Backup automatisch mounten und nachher wieder umounten. In /etc/fstab habe ich den Stick UUID=1516175A28952C11 /media/Backup ntfs noauto,nofail,users,uid=pi,gid=pi 0 0 hinterlegt. Ich habe das in allen Variationen mit DEFAULT_BEFORE_STOPSERVICES="mount UUID=1516175A28952C11 /media/Backup" und DEFAULT_AFTER_STARTSERVICES=“…“ versucht. Ich bekomme leider immer den Fehler: RBK0027E: Kein externes Gerät an /media/Backup verbunden. Die SD Karte würde für das Backup benutzt werden. Läuft das wirklich nicht ohne Wrapper?
    Zitieren
    #48 framp 2019-12-11 11:00
    Hello Alex,

    thank you very much for the heads up. I added your link. Unfortunately I just notices Snoopy Street Fair is no longer available in Play Store. But I will keep this page for reference.

    Cu framp
    Zitieren
    #47 Alex Nordeen 2019-12-11 09:17
    Hi,

    Sorry to intrude your mailbox.

    I saw you linked to https://developer.android.com/studio/command-line/adb from https://www.linux-tips-and-tricks.de/de/linux/425-snoopy-s-street-fair-wie-kann-man-seine-snoopy-dollars-und-xps-unter-android-vermehren/

    I would like to bring to your attention a resource I recently created – Guru99. https://www.guru99.com/adb-connect.html The content is up to date and very in-depth.

    Thought you might like this one.

    Thanks!
    Alex
    Zitieren
    #46 framp 2019-10-27 17:22
    Moin PE,

    vermutlich benutzt Du den partitionsorientierten Modus. De sichert kein externe Rootpartition.

    Cu framp
    Zitieren
    #45 PE 2019-10-27 15:12
    Ich boote meinen Raspberry Pi 3 von einem USB-Stick /dev/sda2.
    Ich habe versucht diesen ebenfalls mit raspiBackup zu sichern, aber egal was ich einstelle, es werden nur die beiden Partitionen mmcblk0p1 und 2 gesichert. Manuelles Sichern mit tar oder dd von sda1 und sda2 funktioniert problemlos. Geht es überhaupt mit raspiBackup und wenn ja, was muss man einstellen?
    Zitieren
    #44 framp 2019-10-10 14:31
    Moin Joerg,

    raspiBackup benutzt einen eMail Client um eMails zu senden. Dazu muss ein eMail Client richtig aufgesetzt werden.

    Aber solange Du nicht mit Code:echo "world" | mail -s "Hello" <eMailAdresse> eine eMail von Deiner Raspberry erfolgreich senden kannst macht es keinen Sinn es mit raspiBackup zu probieren. Vielleicht hilft Dir dieser Thread um z.B. exim2 aufzusetzen. Du wirst da auch Fragen von mir finden denn auch ich bin kein eMail Spezl und immer froh wenn ich exim2 wieder am Laufen habe. :roll:

    Cu framp
    Zitieren
    #43 Joerg 2019-10-10 11:50
    Vor ein paar Tagen habe ich Dein Projekt ausgiebig gelobt. Alles funktioniert wie es soll.
    Nur leider bin ich scheinbar zu blöd hinzubekommen dass auch mails versendet werden.
    Gibt es hierzu eine detailierte Beschreibung? Hatte ich nicht gefunden.
    Über Hilfe wäre ich dankbar
    Zitieren
    #42 framp 2019-04-26 23:50
    Moin,

    die Option -e erwartet eine eMailadresse. Die fehlt. Warum keine entsprechende Fehlermeldung ausgegeben wird muss ich untersuchen.

    Cu framp
    Zitieren
    #41 Installer Aufruf 2019-04-26 17:37
    Hallo,
    versuche gerade das Backuptool zum Laufen zu bringen, leider bekomme ich einige Fehlermeldungen:

    root@raspberrypi:/# sudo raspiBackup.sh -t tar -k 4 -e /backup
    --- RBK0009I: raspberrypi: raspiBackup.sh V0.6.4.3-beta (4b891fe) started at Fri Apr 26 17:33:19 CEST 2019.
    !!! RBK0165W: =========> NOTE NOTE
    Zitieren
    #40 framp 2019-03-07 20:41
    Moin Michael,

    Zitat:
    In der crontab -e sehe ich keine Einträge.
    Auf dieser Seite steht weiter unten Die raspiBackup Cron Konfigurationsdatei ist /etc/cron.d/raspiBackup und nicht in /etc/crontab. D.h. mit crontab -e siehst Du nichts.

    Weiter unten auf der Seite wird auf FAQ18 verlinked. Dort ist beschrieben was man machen muss um Services zu stoppen und zu starten. Das geht leider noch nicht im Installer. Wenn ich mal Zeit habe baue ich das auch noch ein.

    Warum beim zweiten Backup eine cifs8d liegt kann ich mir nicht erklären. Du solltest im Backupverzeichnis eine Logdatei mit dem Namen raspiBackup.log finden. Schicke die mir mal fuer den zweiten Versuch per eMail zu (eMail siehe Kontakt Seite).

    Wenn Du das Wrapperscript verwenden willst musst Du das Script in der Crontab aufrufen und im Script am Ende eine der beiden Zeilen einschalten indem Du das # Zeichen am Anfang der Zeile entfernst.

    Cu framp
    Zitieren
    #39 Michael Feske 2019-03-07 10:40
    Erstmal herzlichen Dank für dieses Tool ! Über das UI war die Installation recht einfach. Aber jetzt kommen dann die kleinen und großen Problemchen.
    In der crontab -e sehe ich keine Einträge.
    Bei mir läuft FHEM, im Backup log wird jedoch behauptet: !!! RBK0157W: Keine Services sind zu stoppen.
    Da ich evt. einen Restore über Windows durchführen muss, habe ich mich für die dd Methode entschieden. Das hat auch schon mal nach der ersten Einrichtung geklappt, im nas lage im Pfad /mnt/nas/raspberrypi/raspberrypi-ddz-backup-20190306-073132/ eine raspberrypi-ddz-backup-20190306-073132.img.gz. Heute habe ich dann mal mit dem UI den Backupzeitpunkt angepasst. Jetzt liegt unter /mnt/nas/raspberrypi/raspberrypi-ddz-backup-20190307-090001 nur eine 1024 -rwxrwxrwx 1 pi pi 559 Mär 7 08:59 cifs8d :-(
    Wie wende ich eigentlich das wrapperscript an ? Ziel soll sein später noch pishrinkzu nutzen, wenn die anderen Sachen erstmal funktionieren. Ich hab noch nicht mal einen Restore gemacht. Gruß
    Micha
    Zitieren
    #38 framp 2018-06-18 21:27
    zitiere framp:
    Moin Holger,

    ich habe das wrapperscript eben mit code samples versehen wie man pishrink aufrufen kann. Allerdings musst Du dazu die aktuellste raspiBackup version noch mal installieren.

    Cu framp

    zitiere framp:
    Moin Holger,

    ich habe das wrapperscript eben mit code samples versehen wie man pishrink aufrufen kann. Allerdings musst Du dazu die aktuellste raspiBackup version noch mal installieren.

    Cu framp

    Gut
    ch habe das wrapperscript eben mit code samples versehen wie man pishrink aufrufen kann. Allerdings musst Du dazu die aktuellste raspiBackup version noch mal installieren.
    Zitieren
    #37 framp 2018-05-12 17:35
    Moin Holger,

    ich habe das wrapperscript eben mit code samples versehen wie man pishrink aufrufen kann. Allerdings musst Du dazu die aktuellste raspiBackup version noch mal installieren.

    Cu framp
    Zitieren
    #36 framp 2018-05-11 21:39
    Moin Holger,

    das geht prinzipiell mit den Wrapperscript auf github. Dort musst Du am Ende nach dem Aufruf von raspiBackup noch den Aufruf von pishrink aufnehmen. Alternativ kann auch raspiBackup das Image verkleinern. Allerdings musst Du dazu die Partitionen anpassen. Details dazu findest Du hier

    Ich werde mir auch mal ansehen ob ich pishrink standardmaessing als Option nach dem Backup aufrufbar mache. Das wird aber wenn dann erst in der naechsten raspiBackupVersion verfuegbar sein und die wird erst in ca 6 Monaten verfuegbar sein.

    Cu framp
    Zitieren
    #35 Holger 2018-05-11 10:43
    Hallo,

    Ich möchte gerne nach einem erfolgreichen DD Backup (raspiBackup.sh) über meines Raspberry ein script (pishrink.sh) noch über das erstellte Backup laufen lassenn.
    Link: https://linuxundich.de/raspberry-pi/pishrink-verkleinert-raspberry-pi-images/

    Ist es möglich dieses am Ende des raspiBackup.sh script noch einzufügen und das original Backup eventuell noch zu löschen. Wenn ja wie mache ich das?

    Vielen Dank schon im voraus

    Gruß Holger
    Zitieren
    #34 framp 2018-04-08 20:10
    Moin Stephan,

    ich habe mir das noch mal durch den Kopf gehen lassen. Ich wuerde einen vollstaendigen Stop und Start aller Services in raspiBackup einbauen wie es in dem helperscript getan wird. Voraussetzung ist aber dass Du Dich als Tester zur Verfuegung stellst :-)

    Cu framp
    Zitieren
    #33 framp 2018-04-08 15:54
    Moin Stephan,

    in den ersten Versionen von raspiBackup wurde nichts gestartet und gestoppt. Die Funktion wurde erst später eingebaut. Es gibt eine Menge Leute die stoppen nichts und ihre Backups sind OK.
    Es gibt aber auch Leute die wollen ein Coldbackup, d.h. ein Backup von einem nicht laufenden System. Das kann man z.B. so machen dass man ein zweites kleines System auf der SD hat welches gebootet wird und dann der Backup des anderen gestoppten Systems vorgenommen wird.

    Wenn ich Dich richtig verstehe moechtest Du dass es eine Option bei raspiBackup gibt die vor dem Backup alles stopped und anschliessend alles wieder startet.
    Dazu gibt es schon eine Loesung ;-) Siehe stopStartAllServicesWrapper. Nur ist es nicht in raspiBackup integriert und kann per Option ein oder ausgeschaltet werden.

    Prinzipiell kann ich das einbauen. Da ich diese Funktion fuer mich nicht benoetige mache ich das aber nur wenn ich sehe dass es sich lohnt den Aufwand zu treiben und es auch wirklich eine groessere Anzahl Leute gibt die diese Funktion benoetigen und benutzen werden.

    Du koenntest ja mal einen Issue dazu im Git aufmachen. Wenn es dann eine gewisse Menge von :thumbsup: gibt wuerde ich es einbauen.

    Cu framp
    Zitieren
    #32 Stephan Neumeister 2018-04-08 15:10
    Hallo,

    Zum "raspiBackup":
    Ein schönes Tool, das im Prinzip auch tut.
    Was mich ein bischen stört, dass ich explizit angeben muss, welche Services zu stoppen und am Ende wieder zu starten sind... bzw. nicht mehr gestartet werden, wenn das Skript auf irgendwelche Fehler stösst.

    Wäre es nicht denkbar, das Backup in einen eignen Runlevel unterzubringen? Also z.B. den Single-User-Mode als Templete zu nutzen, dann die Mindest-Resourcen (network, nfs, usb,...) zu starten.... backup.... und zurück zum Standard-Runlevel (oder einfach reboot in den definierten Standard).

    Damit wäre dann immer (unabhängig was installiert ist oder noch wird) gewährleistet, dass nichts läuft, was zu Inkonsistenzen führt. Zudem könnte ja dann noch ein Timer mitlaufen, der im Fehlerfalle den Backup-Runlevel IMMER nach max. Zeit beendet und mit dem Standard-Runlevel (oder reboot) in definiertem Zustand landet.

    Nur so als Anregung zu sehen.... :-)
    Zitieren
    #31 Nastra 2018-02-14 13:37
    Werde ich später machen wenn ich zu Hause bin .-)

    Gruß Nastra
    Zitieren
    #30 framp 2018-02-14 11:16
    Das ist ein Bug :oops: . Erstelle bitte ein Log mit Option -l debug und schicke es mir an meine Email (siehe Kontaktseite)

    Cu framp
    Zitieren
    #29 Nastra 2018-02-14 08:58
    Cool, vielen Dank für die Antwort. Kannst du mir noch sagen wie ich das einstellen muss. Bekomme beim starten immer gesagt Boot Medium nicht erkannt -.-
    Zitieren
    #28 framp 2018-02-14 08:21
    Moin Nastra,

    Ja das ist unterstützt.

    Cu framp
    Zitieren
    #27 Nastra 2018-02-14 06:42
    Hallo,

    kurzen Frage zu dem supper Tool.

    Ich habe mein Image von einem USB Stick auf dem Pi gestartet ist es möglich mit diesem Tool auch von USB auf einen anderen USB zu sichern?
    Zitieren
    #26 framp 2018-02-13 19:11
    Moin Stefan,

    vielen Dank für Dein Feedback. Es freut mich dass Du es jetzt hinbekommen hast :thumbsup:

    In der nächsten Version von raspiBackup wird es einen erweiterten Optionsparser geben. Mir sind langsam die Optionen ausgegangen da immer wieder neue Wünsche an mich herangetragen wurden :-)

    Ich nehme Dein Problem zum Anlass eine Option einzuführen mit der man die VersendereMailAdresse definieren kann ;-)

    Damit ich es nicht vergesse habe ich gleich mal einen git Issue aufgemacht

    Cu framp
    Zitieren