Aus Versehen habe ich diese Joomla Webseite mit einer zweiten initialen Joomlainstallation übergebügelt. Autsch! 
 
Wer Joomla bei Strato benutzt sollte noch meinen PerformanceErfahrungsberichtbei Strato lesen. 
 
Erfreulicherweise hielten sich die Schäden in Grenzen.  Es gab ein paar Sampleseiten, die ich einfach wieder löschen konnte. Allerdings gab es eine Menge doppelte Einträge im Adminbereich bei Menus, die Anzeige der Onlineuser und eMails war doppelt usw. Ich hatte also das doppelte Lottchen im Adminbereich ...
 
Bei Strato besitze ich nur eine mySQL DB. Man kann aber ohne Probleme mehrere Joomlas installieren. Nur muss man den StandardPrefix der mySQL DB von Joomla ändern. Da ich eine weitere Joomlainstallation auf einer anderen Webseite vornehmen wollte hatte ich vorher noch ein paar Dinge testen wollen und Joomla noch ein zweites Mal in dieselbe DB installiert - mit anderem DB Prefix. Da Fehler auftraten mußte ich die DB per phpMyAdmin löschen. Bei zweiten Installieren vergaß ich dummerweise den sql Prefix zu ändern und habe damit auf einer bestehenen - nämlich diese Webseite - zum zweiten Mal joomla installiert. Nach kurzem brach die Installation mit einer Fehlermeldung ab und mir wurde mein Fehler bewußt.
  
Danach postete ich Joomla CMS Forum mein Problem da ich dachte das würde schon öfter vorgekommen sein und jemand wüßte wie ich das Doppelte Lottchen wieder loswerden könnte.  Leider keine Antwort. Nach einer gewissen Zeit postete ich das Problem auch im Linux-Club und bekam dort auch keine direkte Lösung - aber verschiedene Hinweise wo ich suchen sollte.
 
Daraufhin habe ich die mySQLDB per phpMyAdmin exportiert  und die gesamte Joomlaumgebung bei mir lokal auf einem SuSE 9.3 dupliziert und angefangen zu suchen was da wohl bei der zweiten Installation passiert ist und wie ich das wieder korrigieren kann. Da ich keine php Kenntnisse habe bin ich mal die verschiedenen Adminseiten durchgegangen und schließlich fiel mir auf daß es eine Menge Module gab, die doppelt installiert waren. Leider ließen sich diese doppelten Module nicht im joomla GUI löschen. Also bin ich ins phpMyAdmin gegangen und habe mir die jos_modules Tabelle angesehen. Auch da tauchten die doppelten Module auf. Das Module mit der ID 1 war das Poll Module. Dieses fand ich weiter hinten mit einer wesentlich höheren ID (irgendwas um die 70). Dahinte befanden sich alle weiteren Module Doubletten. Also habe ich mit phpMyAdmin alle Module ab Nr. 2 von dem Pollmodule gelöscht - erst lokal - dann hier auf der Webseite - und nun gibt es kein Doppeltes Lottchen mehr. War eigentlich - wenn man weiß wo und wie - recht einfach das Problem zu beheben. 
Kommentar schreiben
Hinweis:
Die eMail ist versteckt und nicht öffentlich sichtbar. Sie wird benutzt um über neue Kommentare zu informieren.